gcc.mk 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334
  1. ################################################################################
  2. #
  3. # Common variables for the gcc-initial and gcc-final packages.
  4. #
  5. ################################################################################
  6. #
  7. # Version, site and source
  8. #
  9. GCC_VERSION = $(call qstrip,$(BR2_GCC_VERSION))
  10. ifeq ($(BR2_GCC_VERSION_ARC),y)
  11. GCC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gcc,$(GCC_VERSION))
  12. GCC_SOURCE = gcc-$(GCC_VERSION).tar.gz
  13. else
  14. GCC_SITE = $(BR2_GNU_MIRROR:/=)/gcc/gcc-$(GCC_VERSION)
  15. GCC_SOURCE = gcc-$(GCC_VERSION).tar.xz
  16. endif
  17. #
  18. # Xtensa special hook
  19. #
  20. define HOST_GCC_XTENSA_OVERLAY_EXTRACT
  21. $(call arch-xtensa-overlay-extract,$(@D),gcc)
  22. endef
  23. #
  24. # Apply patches
  25. #
  26. # gcc is a special package, not named gcc, but gcc-initial and
  27. # gcc-final, but patches are nonetheless stored in package/gcc in the
  28. # tree, and potentially in BR2_GLOBAL_PATCH_DIR directories as well.
  29. define HOST_GCC_APPLY_PATCHES
  30. for patchdir in \
  31. package/gcc/$(GCC_VERSION) \
  32. $(addsuffix /gcc/$(GCC_VERSION),$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  33. $(addsuffix /gcc,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) ; do \
  34. if test -d $${patchdir}; then \
  35. $(APPLY_PATCHES) $(@D) $${patchdir} \*.patch || exit 1; \
  36. fi; \
  37. done
  38. $(HOST_GCC_APPLY_POWERPC_PATCH)
  39. endef
  40. HOST_GCC_EXCLUDES = \
  41. libjava/* libgo/*
  42. #
  43. # Create 'build' directory and configure symlink
  44. #
  45. define HOST_GCC_CONFIGURE_SYMLINK
  46. mkdir -p $(@D)/build
  47. ln -sf ../configure $(@D)/build/configure
  48. endef
  49. #
  50. # Common configuration options
  51. #
  52. HOST_GCC_COMMON_DEPENDENCIES = \
  53. host-binutils \
  54. host-gmp \
  55. host-mpc \
  56. host-mpfr \
  57. $(if $(BR2_BINFMT_FLAT),host-elf2flt)
  58. HOST_GCC_COMMON_CONF_OPTS = \
  59. --target=$(GNU_TARGET_NAME) \
  60. --with-sysroot=$(STAGING_DIR) \
  61. --enable-__cxa_atexit \
  62. --with-gnu-ld \
  63. --disable-libssp \
  64. --disable-multilib \
  65. --disable-decimal-float \
  66. --with-gmp=$(HOST_DIR) \
  67. --with-mpc=$(HOST_DIR) \
  68. --with-mpfr=$(HOST_DIR) \
  69. --with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
  70. --with-bugurl="http://bugs.buildroot.net/" \
  71. --without-zstd
  72. # Don't build documentation. It takes up extra space / build time,
  73. # and sometimes needs specific makeinfo versions to work
  74. HOST_GCC_COMMON_CONF_ENV = \
  75. MAKEINFO=missing
  76. GCC_COMMON_TARGET_CFLAGS = $(TARGET_CFLAGS)
  77. GCC_COMMON_TARGET_CXXFLAGS = $(TARGET_CXXFLAGS)
  78. # used to fix ../../../../libsanitizer/libbacktrace/../../libbacktrace/elf.c:772:21: error: 'st.st_mode' may be used uninitialized in this function [-Werror=maybe-uninitialized]
  79. ifeq ($(BR2_ENABLE_DEBUG),y)
  80. GCC_COMMON_TARGET_CFLAGS += -Wno-error
  81. endif
  82. # Make sure libgcc & libstdc++ always get built with -matomic on ARC700
  83. ifeq ($(GCC_TARGET_CPU):$(BR2_ARC_ATOMIC_EXT),arc700:y)
  84. GCC_COMMON_TARGET_CFLAGS += -matomic
  85. GCC_COMMON_TARGET_CXXFLAGS += -matomic
  86. endif
  87. # Propagate options used for target software building to GCC target libs
  88. HOST_GCC_COMMON_CONF_ENV += CFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CFLAGS)"
  89. HOST_GCC_COMMON_CONF_ENV += CXXFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CXXFLAGS)"
  90. HOST_GCC_COMMON_CONF_ENV += AR_FOR_TARGET=gcc-ar NM_FOR_TARGET=gcc-nm RANLIB_FOR_TARGET=gcc-ranlib
  91. # libitm needs sparc V9+
  92. ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
  93. HOST_GCC_COMMON_CONF_OPTS += --disable-libitm
  94. endif
  95. # libmpx uses secure_getenv and struct _libc_fpstate not present in musl
  96. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_MUSL)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),yy)
  97. HOST_GCC_COMMON_CONF_OPTS += --disable-libmpx
  98. endif
  99. # quadmath support requires wchar
  100. ifeq ($(BR2_USE_WCHAR)$(BR2_TOOLCHAIN_HAS_LIBQUADMATH),yy)
  101. HOST_GCC_COMMON_CONF_OPTS += --enable-libquadmath --enable-libquadmath-support
  102. else
  103. HOST_GCC_COMMON_CONF_OPTS += --disable-libquadmath --disable-libquadmath-support
  104. endif
  105. # libsanitizer requires wordexp, not in default uClibc config. Also
  106. # doesn't build properly with musl.
  107. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_TOOLCHAIN_BUILDROOT_MUSL),y)
  108. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  109. endif
  110. # libsanitizer is broken for SPARC
  111. # https://bugs.busybox.net/show_bug.cgi?id=7951
  112. ifeq ($(BR2_sparc)$(BR2_sparc64),y)
  113. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  114. endif
  115. # The logic in libbacktrace/configure.ac to detect if __sync builtins
  116. # are available assumes they are as soon as target_subdir is not
  117. # empty, i.e when cross-compiling. However, some platforms do not have
  118. # __sync builtins, so help the configure script a bit.
  119. ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
  120. HOST_GCC_COMMON_CONF_ENV += target_configargs="libbacktrace_cv_sys_sync=no"
  121. endif
  122. # TLS support is not needed on uClibc/no-thread and
  123. # uClibc/linux-threads, otherwise, for all other situations (glibc,
  124. # musl and uClibc/NPTL), we need it.
  125. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_PTHREADS)$(BR2_PTHREADS_NONE),yy)
  126. HOST_GCC_COMMON_CONF_OPTS += --disable-tls
  127. else
  128. HOST_GCC_COMMON_CONF_OPTS += --enable-tls
  129. endif
  130. ifeq ($(BR2_GCC_ENABLE_LTO),y)
  131. HOST_GCC_COMMON_CONF_OPTS += --enable-plugins --enable-lto
  132. endif
  133. ifeq ($(BR2_PTHREADS_NONE),y)
  134. HOST_GCC_COMMON_CONF_OPTS += \
  135. --disable-threads \
  136. --disable-libitm \
  137. --disable-libatomic
  138. else
  139. HOST_GCC_COMMON_CONF_OPTS += --enable-threads
  140. endif
  141. # gcc 5 doesn't need cloog any more, see
  142. # https://gcc.gnu.org/gcc-5/changes.html and we don't support graphite
  143. # on GCC 4.9.x, so only isl is needed.
  144. ifeq ($(BR2_GCC_ENABLE_GRAPHITE),y)
  145. HOST_GCC_COMMON_DEPENDENCIES += host-isl
  146. HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)
  147. else
  148. HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
  149. endif
  150. ifeq ($(BR2_arc),y)
  151. HOST_GCC_COMMON_DEPENDENCIES += host-flex host-bison
  152. endif
  153. ifeq ($(BR2_SOFT_FLOAT),y)
  154. # only mips*-*-*, arm*-*-* and sparc*-*-* accept --with-float
  155. # powerpc seems to be needing it as well
  156. ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_powerpc)$(BR2_sparc),y)
  157. HOST_GCC_COMMON_CONF_OPTS += --with-float=soft
  158. endif
  159. endif
  160. # Determine arch/tune/abi/cpu options
  161. ifneq ($(GCC_TARGET_ARCH),)
  162. HOST_GCC_COMMON_CONF_OPTS += --with-arch="$(GCC_TARGET_ARCH)"
  163. endif
  164. ifneq ($(GCC_TARGET_ABI),)
  165. HOST_GCC_COMMON_CONF_OPTS += --with-abi="$(GCC_TARGET_ABI)"
  166. endif
  167. ifeq ($(BR2_TOOLCHAIN_HAS_MNAN_OPTION),y)
  168. ifneq ($(GCC_TARGET_NAN),)
  169. HOST_GCC_COMMON_CONF_OPTS += --with-nan="$(GCC_TARGET_NAN)"
  170. endif
  171. endif
  172. ifneq ($(GCC_TARGET_FP32_MODE),)
  173. HOST_GCC_COMMON_CONF_OPTS += --with-fp-32="$(GCC_TARGET_FP32_MODE)"
  174. endif
  175. ifneq ($(GCC_TARGET_CPU),)
  176. HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(GCC_TARGET_CPU)
  177. endif
  178. ifneq ($(GCC_TARGET_FPU),)
  179. HOST_GCC_COMMON_CONF_OPTS += --with-fpu=$(GCC_TARGET_FPU)
  180. endif
  181. ifneq ($(GCC_TARGET_FLOAT_ABI),)
  182. HOST_GCC_COMMON_CONF_OPTS += --with-float=$(GCC_TARGET_FLOAT_ABI)
  183. endif
  184. ifneq ($(GCC_TARGET_MODE),)
  185. HOST_GCC_COMMON_CONF_OPTS += --with-mode=$(GCC_TARGET_MODE)
  186. endif
  187. # Enable proper double/long double for SPE ABI
  188. ifeq ($(BR2_powerpc_SPE),y)
  189. HOST_GCC_COMMON_CONF_OPTS += \
  190. --enable-obsolete \
  191. --enable-e500_double \
  192. --with-long-double-128
  193. endif
  194. # Set default to Secure-PLT to prevent run-time
  195. # generation of PLT stubs (supports RELRO and
  196. # SELinux non-exemem capabilities)
  197. ifeq ($(BR2_powerpc)$(BR2_powerpc64),y)
  198. HOST_GCC_COMMON_CONF_OPTS += --enable-secureplt
  199. endif
  200. # PowerPC64 big endian by default uses the elfv1 ABI, and PowerPC 64
  201. # little endian by default uses the elfv2 ABI. However, musl has
  202. # decided to use the elfv2 ABI for both, so we force the elfv2 ABI for
  203. # Power64 big endian when the selected C library is musl.
  204. ifeq ($(BR2_TOOLCHAIN_USES_MUSL)$(BR2_powerpc64),yy)
  205. HOST_GCC_COMMON_CONF_OPTS += \
  206. --with-abi=elfv2 \
  207. --without-long-double-128
  208. endif
  209. # Since glibc >= 2.26, poerpc64le requires double/long double which
  210. # requires at least gcc 6.2.
  211. # See sysdeps/powerpc/powerpc64le/configure.ac
  212. ifeq ($(BR2_TOOLCHAIN_USES_GLIBC)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6)$(BR2_powerpc64le),yyy)
  213. HOST_GCC_COMMON_CONF_OPTS += \
  214. --with-long-double-128
  215. endif
  216. ifeq ($(BR2_s390x),y)
  217. HOST_GCC_COMMON_CONF_OPTS += \
  218. --with-long-double-128
  219. endif
  220. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CROSS_PATH_SUFFIX='".br_real"'
  221. # For gcc-initial, we need to tell gcc that the C library will be
  222. # providing the ssp support, as it can't guess it since the C library
  223. # hasn't been built yet.
  224. #
  225. # For gcc-final, the gcc logic to detect whether SSP support is
  226. # available or not in the C library is not working properly for
  227. # uClibc, so let's be explicit as well.
  228. HOST_GCC_COMMON_MAKE_OPTS = \
  229. gcc_cv_libc_provides_ssp=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
  230. ifeq ($(BR2_CCACHE),y)
  231. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(GCC_DL_DIR)/$(GCC_SOURCE)
  232. # Cfr. PATCH_BASE_DIRS in .stamp_patched, but we catch both versioned
  233. # and unversioned patches unconditionally. Moreover, to facilitate the
  234. # addition of gcc patches in BR2_GLOBAL_PATCH_DIR, we allow them to be
  235. # stored in a sub-directory called 'gcc' even if it's not technically
  236. # the name of the package.
  237. HOST_GCC_COMMON_CCACHE_HASH_FILES += \
  238. $(sort $(wildcard \
  239. package/gcc/$(GCC_VERSION)/*.patch \
  240. $(addsuffix /$($(PKG)_RAWNAME)/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  241. $(addsuffix /$($(PKG)_RAWNAME)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  242. $(addsuffix /gcc/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  243. $(addsuffix /gcc/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR)))))
  244. ifeq ($(BR2_xtensa),y)
  245. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(ARCH_XTENSA_OVERLAY_TAR)
  246. endif
  247. # _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
  248. # and a reference to the Buildroot git revision (BR2_VERSION_FULL),
  249. # so substitute those away.
  250. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CCACHE_HASH=\"`\
  251. printf '%s\n' $(subst $(HOST_DIR),@HOST_DIR@,\
  252. $(subst --with-pkgversion="Buildroot $(BR2_VERSION_FULL)",,$($(PKG)_CONF_OPTS))) \
  253. | sha256sum - $(HOST_GCC_COMMON_CCACHE_HASH_FILES) \
  254. | cut -c -64 | tr -d '\n'`\"
  255. endif # BR2_CCACHE
  256. # The LTO support in gcc creates wrappers for ar, ranlib and nm which load
  257. # the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
  258. # *-gcc-nm and should be used instead of the real programs when -flto is
  259. # used. However, we should not add the toolchain wrapper for them, and they
  260. # match the *cc-* pattern. Therefore, an additional case is added for *-ar,
  261. # *-ranlib and *-nm.
  262. # According to gfortran manpage, it supports all options supported by gcc, so
  263. # add gfortran to the list of the program called via the Buildroot wrapper.
  264. # Avoid that a .br_real is symlinked a second time.
  265. # Also create <arch>-linux-<tool> symlinks.
  266. define HOST_GCC_INSTALL_WRAPPER_AND_SIMPLE_SYMLINKS
  267. $(Q)cd $(HOST_DIR)/bin; \
  268. for i in $(GNU_TARGET_NAME)-*; do \
  269. case "$$i" in \
  270. *.br_real) \
  271. ;; \
  272. *-ar|*-ranlib|*-nm) \
  273. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  274. ;; \
  275. *cc|*cc-*|*++|*++-*|*cpp|*-gfortran|*-gdc) \
  276. rm -f $$i.br_real; \
  277. mv $$i $$i.br_real; \
  278. ln -sf toolchain-wrapper $$i; \
  279. ln -sf toolchain-wrapper $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  280. ln -snf $$i.br_real $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}.br_real; \
  281. ;; \
  282. *) \
  283. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  284. ;; \
  285. esac; \
  286. done
  287. endef
  288. include $(sort $(wildcard package/gcc/*/*.mk))