Parcourir la source

package: bluez5_utils: add obexctl tool support

add obexctl tool support

Signed-off-by: Ziv Xu <ziv.xu@starfivetech.com>
Ziv Xu il y a 4 mois
Parent
commit
d66ffcc5dd
1 fichiers modifiés avec 7 ajouts et 0 suppressions
  1. 7 0
      package/bluez5_utils/bluez5_utils.mk

+ 7 - 0
package/bluez5_utils/bluez5_utils.mk

@@ -138,4 +138,11 @@ define BLUEZ5_UTILS_INSTALL_INIT_SYSV
 		$(TARGET_DIR)/etc/init.d/S40bluetooth
 endef
 
+ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS_OBEX),y)
+define BLUEZ5_UTILS_INSTALL_TOOLS
+	$(INSTALL) -m 0755 $(@D)/tools/obexctl $(TARGET_DIR)/usr/bin/obexctl
+endef
+endif
+BLUEZ5_UTILS_POST_INSTALL_TARGET_HOOKS += BLUEZ5_UTILS_INSTALL_TOOLS
+
 $(eval $(autotools-package))