Browse Source

libcamera: relocation the sensors_pipeline.yaml to /etc/starfive/

Signed-off-by: Andy Hu <andy.hu@starfivetech.com>
Andy Hu 2 years ago
parent
commit
7253674b8f

+ 1 - 1
package/libcamera/0008-support-use-yaml-file-to-config-sensor-pipeline.patch

@@ -97,7 +97,7 @@ index bb513387..8afe5e89 100644
 -static constexpr unsigned int MAX_STREAMS = 2;
 -static const Size OUTPUT_MIN_SIZE = { 8, 8 };
 -static const Size OUTPUT_MAX_SIZE = { 8192, 8192 };
-+#define PIPELINE_CONFIG_FILENAME "/root/sensors_pipeline.yaml"
++#define PIPELINE_CONFIG_FILENAME "/etc/starfive/sensors_pipeline.yaml"
  
  namespace {
  

+ 1 - 1
package/libcamera/0010-libcamera-add-framerate-for-request-pad-src.patch

@@ -100,7 +100,7 @@ index 00000000..b2a558aa
 ++++ b/src/libcamera/pipeline/starfive/starfive.cpp	2022-01-11 10:13:31.200266219 +0800
 +@@ -44,6 +44,9 @@
 + 
-+ #define PIPELINE_CONFIG_FILENAME "/root/sensors_pipeline.yaml"
++ #define PIPELINE_CONFIG_FILENAME "/etc/starfive/sensors_pipeline.yaml"
 + 
 ++#define DEFAULT_FRAMERATE_NUM 25;
 ++#define DEFAULT_FRAMERATE_DENOM 1;

+ 2 - 1
package/libcamera/libcamera.mk

@@ -97,7 +97,8 @@ LIBCAMERA_DEPENDENCIES += yaml-cpp
 endif
 
 define LIBCAMERA_HOOK_EXTRA
-	$(INSTALL) -D -m 0644 $(@D)/src/libcamera/pipeline/starfive/sensors_pipeline.yaml $(TARGET_DIR)/root/sensors_pipeline.yaml
+	mkdir -p $(TARGET_DIR)/etc/starfive
+	$(INSTALL) -D -m 0644 $(@D)/src/libcamera/pipeline/starfive/sensors_pipeline.yaml $(TARGET_DIR)/etc/starfive/sensors_pipeline.yaml
 endef
 LIBCAMERA_POST_INSTALL_TARGET_HOOKS = LIBCAMERA_HOOK_EXTRA