rules 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. export DH_VERBOSE=1
  10. # These are used for cross-compiling and for saving the configure script
  11. # from having to guess our platform (since we know it already)
  12. DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  13. DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  14. CFLAGS = -Wall -g
  15. ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
  16. CFLAGS += -O0
  17. else
  18. CFLAGS += -O2
  19. endif
  20. ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
  21. CFLAGS += -g
  22. endif
  23. ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
  24. INSTALL_PROGRAM += -s
  25. endif
  26. build:
  27. dh_testdir
  28. # Add here commands to compile the package.
  29. #$(MAKE)
  30. # No build.
  31. rm ChangeLog; ln -s CHANGELOG ChangeLog;
  32. touch $@
  33. clean:
  34. dh_testdir
  35. dh_testroot
  36. rm -f build-stamp
  37. # Add here commands to clean up after the build process.
  38. #-$(MAKE) distclean
  39. # No clean.
  40. dh_clean
  41. install: build
  42. dh_testdir
  43. dh_testroot
  44. dh_clean -k
  45. dh_installdirs
  46. # Add here commands to install the package into debian/gcc4ti.
  47. #$(MAKE) DESTDIR=$(CURDIR)/debian/gcc4ti install
  48. # No install.
  49. mkdir -p /tmp/gcc4ti
  50. export TIGCC=/tmp/gcc4ti
  51. #./scripts/Install_All
  52. mkdir -p $(CURDIR)/debian/gcc4ti/usr
  53. mkdir -p $(CURDIR)/debian/gcc4ti/usr/local
  54. mkdir -p $(CURDIR)/debian/gcc4ti/usr/local/share
  55. mkdir -p $(CURDIR)/debian/gcc4ti/usr/local/share/gcc4ti
  56. cp -R /tmp/gcc4ti $(CURDIR)/debian/gcc4ti/usr/local/share
  57. # Build architecture-independent files here.
  58. binary-indep: build install
  59. # Build architecture-dependent files here.
  60. binary-arch: build install
  61. dh_testdir
  62. dh_testroot
  63. dh_installchangelogs ChangeLog
  64. dh_installdocs
  65. dh_installexamples
  66. dh_install
  67. dh_installman
  68. dh_installmenu
  69. # dh_installpam
  70. # dh_installmime
  71. dh_link
  72. dh_strip
  73. dh_compress
  74. dh_fixperms
  75. dh_makeshlibs
  76. dh_installdeb
  77. dh_shlibdeps
  78. dh_gencontrol
  79. dh_md5sums
  80. dh_builddeb
  81. binary: binary-indep binary-arch
  82. .PHONY: build clean binary-indep binary-arch binary install