Browse Source

package/perl-math-int64: new package

Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Joeri Barbarien 3 years ago
parent
commit
bf07c3c3d6

+ 1 - 0
DEVELOPERS

@@ -2515,6 +2515,7 @@ F:	package/perl-devel-size/
 F:	package/perl-i18n/
 F:	package/perl-locale-maketext-lexicon/
 F:	package/perl-lwp-protocol-https/
+F:	package/perl-math-int64/
 F:	package/perl-math-prime-util/
 F:	package/perl-mime-base64-urlsafe/
 F:	package/perl-mojolicious-plugin-authentication/

+ 1 - 0
package/Config.in

@@ -783,6 +783,7 @@ menu "Perl libraries/modules"
 	source "package/perl-lwp-protocol-https/Config.in"
 	source "package/perl-mail-dkim/Config.in"
 	source "package/perl-mailtools/Config.in"
+	source "package/perl-math-int64/Config.in"
 	source "package/perl-math-prime-util/Config.in"
 	source "package/perl-mime-base64-urlsafe/Config.in"
 	source "package/perl-mime-tools/Config.in"

+ 10 - 0
package/perl-math-int64/Config.in

@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PERL_MATH_INT64
+	bool "perl-math-int64"
+	depends on !BR2_STATIC_LIBS
+	help
+	  Manipulate 64 bits integers in Perl.
+
+	  http://metacpan.org/release/Math-Int64
+
+comment "perl-math-int64 needs a toolchain w/ dynamic library"
+	depends on BR2_STATIC_LIBS

+ 6 - 0
package/perl-math-int64/perl-math-int64.hash

@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5  1ad0ce8b5e903dfe9f7ffbabd8a43014  Math-Int64-0.54.tar.gz
+sha256  dcfc51e698437ea6b9cefe0276215c56cdb6a7f85e3e24a2b6b4189f1960d351  Math-Int64-0.54.tar.gz
+
+# computed by scancpan
+sha256  59feedfdc4f99a746c54e06ac46c4627fb1e29be3bc71756184f92333600f72b  COPYING

+ 14 - 0
package/perl-math-int64/perl-math-int64.mk

@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-math-int64
+#
+################################################################################
+
+PERL_MATH_INT64_VERSION = 0.54
+PERL_MATH_INT64_SOURCE = Math-Int64-$(PERL_MATH_INT64_VERSION).tar.gz
+PERL_MATH_INT64_SITE = $(BR2_CPAN_MIRROR)/authors/id/S/SA/SALVA
+PERL_MATH_INT64_LICENSE = Artistic or GPL-1.0+
+PERL_MATH_INT64_LICENSE_FILES = COPYING
+PERL_MATH_INT64_DISTNAME = Math-Int64
+
+$(eval $(perl-package))