Browse Source

new SDL1.2 with tripple buffering, neon optims

Vincent Buso 1 year ago
parent
commit
a9b038158e

+ 0 - 25
package/sdl/0001-use-correct-directfb-config.patch

@@ -1,25 +0,0 @@
-[PATCH] configure.in: use correct directfb-config in version check
-
-The configure script has just checked for the correct directfb-config
-script, so also use it for the version check instead of whatever
-might be in the path.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- configure.in |    2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-Index: SDL-1.2.15/configure.in
-===================================================================
---- SDL-1.2.15.orig/configure.in
-+++ SDL-1.2.15/configure.in
-@@ -1276,7 +1276,7 @@
-         else
-             set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
-             NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
--            set -- `directfb-config --version | sed 's/\./ /g'`
-+            set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
-             HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
-             if test $HAVE_VERSION -ge $NEED_VERSION; then
-                 DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
-

+ 0 - 60
package/sdl/0002-fix-compilation-with-libx11.patch

@@ -1,60 +0,0 @@
-sdl: Fix compilation with libX11 >= 1.5.99.902
-Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
-
-# HG changeset patch
-# User Azamat H. Hackimov <azamat.hackimov@gmail.com>
-# Date 1370184533 -21600
-# Node ID 91ad7b43317a6387e115ecdf63a49137f47e42c8
-# Parent  f7fd5c3951b9ed922fdf696f7182e71b58a13268
-Fix compilation with libX11 >= 1.5.99.902.
-
-These changes fixes bug #1769 for SDL 1.2
-(http://bugzilla.libsdl.org/show_bug.cgi?id=1769).
-
-diff -r f7fd5c3951b9 -r 91ad7b43317a configure.in
---- a/configure.in	Wed Apr 17 00:56:53 2013 -0700
-+++ b/configure.in	Sun Jun 02 20:48:53 2013 +0600
-@@ -1169,6 +1169,17 @@
-             if test x$definitely_enable_video_x11_xrandr = xyes; then
-                 AC_DEFINE(SDL_VIDEO_DRIVER_X11_XRANDR)
-             fi
-+            AC_MSG_CHECKING(for const parameter to _XData32)
-+            have_const_param_xdata32=no
-+            AC_TRY_COMPILE([
-+              #include <X11/Xlibint.h>
-+              extern int _XData32(Display *dpy,register _Xconst long *data,unsigned len);
-+            ],[
-+            ],[
-+            have_const_param_xdata32=yes
-+            AC_DEFINE(SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32)
-+            ])
-+            AC_MSG_RESULT($have_const_param_xdata32)
-         fi
-     fi
- }
-diff -r f7fd5c3951b9 -r 91ad7b43317a include/SDL_config.h.in
---- a/include/SDL_config.h.in	Wed Apr 17 00:56:53 2013 -0700
-+++ b/include/SDL_config.h.in	Sun Jun 02 20:48:53 2013 +0600
-@@ -283,6 +283,7 @@
- #undef SDL_VIDEO_DRIVER_WINDIB
- #undef SDL_VIDEO_DRIVER_WSCONS
- #undef SDL_VIDEO_DRIVER_X11
-+#undef SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32
- #undef SDL_VIDEO_DRIVER_X11_DGAMOUSE
- #undef SDL_VIDEO_DRIVER_X11_DYNAMIC
- #undef SDL_VIDEO_DRIVER_X11_DYNAMIC_XEXT
-diff -r f7fd5c3951b9 -r 91ad7b43317a src/video/x11/SDL_x11sym.h
---- a/src/video/x11/SDL_x11sym.h	Wed Apr 17 00:56:53 2013 -0700
-+++ b/src/video/x11/SDL_x11sym.h	Sun Jun 02 20:48:53 2013 +0600
-@@ -165,7 +165,11 @@
-  */
- #ifdef LONG64
- SDL_X11_MODULE(IO_32BIT)
-+#if SDL_VIDEO_DRIVER_X11_CONST_PARAM_XDATA32
-+SDL_X11_SYM(int,_XData32,(Display *dpy,register _Xconst long *data,unsigned len),(dpy,data,len),return)
-+#else
- SDL_X11_SYM(int,_XData32,(Display *dpy,register long *data,unsigned len),(dpy,data,len),return)
-+#endif
- SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,len),)
- #endif
- 

+ 0 - 4
package/sdl/sdl.hash

@@ -1,4 +0,0 @@
-# Locally calculated after checking pgp signature
-sha256	d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00	SDL-1.2.15.tar.gz
-# Locally computed
-sha256	bb117c0fbd7f57f64170b690285d7df07c2371b578e3b3cd3aa2e1155ef461a0	COPYING

+ 6 - 3
package/sdl/sdl.mk

@@ -4,9 +4,12 @@
 #
 ################################################################################
 
-SDL_VERSION = 1.2.15
-SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
-SDL_SITE = http://www.libsdl.org/release
+#SDL_VERSION = 1.2.15
+#SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
+#SDL_SITE = http://www.libsdl.org/release
+SDL_VERSION = 1d23399e67582c503e53424c86247fc8f39339a5
+SDL_SITE_METHOD = git
+SDL_SITE = https://github.com/FunKey-Project/SDL-1.2.git
 SDL_LICENSE = LGPL-2.1+
 SDL_LICENSE_FILES = COPYING
 SDL_INSTALL_STAGING = YES