mednafen.mk 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # mednafen
  4. #
  5. ################################################################################
  6. MEDNAFEN_VERSION = cbcdbd8
  7. MEDNAFEN_SITE_METHOD = git
  8. MEDNAFEN_SITE = https://github.com/FunKey-Project/mednafen-git.git
  9. MEDNAFEN_LICENSE = GPL-2.0+
  10. MEDNAFEN_LICENSE_FILES = COPYING
  11. MEDNAFEN_DEPENDENCIES = sdl sdl_image sdl_mixer sdl_ttf zlib
  12. MEDNAFEN_CFLAGS = $(TARGET_CFLAGS) $(subst $\",,$(BR2_TARGET_OPTIMIZATION)) -mfloat-abi=hard
  13. #MEDNAFEN_AUTORECONF = YES
  14. MEDNAFEN_CFLAGS += -ggdb -O3
  15. MEDNAFEN_CFLAGS += -DFUNKEY_FAST_BLIT
  16. #MEDNAFEN_LDFLAGS += -lSDL_ttf -lSDL_image
  17. MEDNAFEN_CONF_OPTS += CXXFLAGS="$(MEDNAFEN_CFLAGS)"
  18. #MEDNAFEN_CONF_OPTS += LDFLAGS="$(MEDNAFEN_LDFLAGS)"
  19. MEDNAFEN_CONF_OPTS += --prefix=/usr/local --bindir=/usr/games --without-libsndfile
  20. MEDNAFEN_CONF_OPTS += --disable-ss --disable-ssfplay --disable-fancy-scalers
  21. #MEDNAFEN_CONF_OPTS += --disable-nes --disable-gba --disable-psx --disable-snes
  22. MEDNAFEN_CONF_ENV += SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
  23. define MEDNAFEN_CREATE_OPK
  24. $(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/local/share/OPKs/Emulators
  25. $(HOST_DIR)/usr/bin/mksquashfs $(MEDNAFEN_PKGDIR)/opk/gamegear $(TARGET_DIR)/usr/local/share/OPKs/Emulators/gamegear_mednafen_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  26. $(HOST_DIR)/usr/bin/mksquashfs $(MEDNAFEN_PKGDIR)/opk/lynx $(TARGET_DIR)/usr/local/share/OPKs/Emulators/lynx_mednafen_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  27. $(HOST_DIR)/usr/bin/mksquashfs $(MEDNAFEN_PKGDIR)/opk/ngp $(TARGET_DIR)/usr/local/share/OPKs/Emulators/ngp_mednafen_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  28. $(HOST_DIR)/usr/bin/mksquashfs $(MEDNAFEN_PKGDIR)/opk/pce $(TARGET_DIR)/usr/local/share/OPKs/Emulators/pce_mednafen_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  29. $(HOST_DIR)/usr/bin/mksquashfs $(MEDNAFEN_PKGDIR)/opk/wonderswan $(TARGET_DIR)/usr/local/share/OPKs/Emulators/wonderswan_mednafen_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  30. endef
  31. MEDNAFEN_POST_INSTALL_TARGET_HOOKS += MEDNAFEN_CREATE_OPK
  32. $(eval $(autotools-package))