gnuboy.mk 1.3 KB

1234567891011121314151617181920212223242526272829303132333435
  1. ################################################################################
  2. #
  3. # gnuboy
  4. #
  5. ################################################################################
  6. GNUBOY_VERSION = dcd6186
  7. GNUBOY_SITE_METHOD = git
  8. GNUBOY_SITE = https://github.com/FunKey-Project/gnuboy.git
  9. GNUBOY_LICENSE = GPL-2.0
  10. GNUBOY_LICENSE_FILES = COPYING
  11. GNUBOY_DEPENDENCIES = sdl sdl_image sdl_mixer sdl_ttf zlib
  12. GNUBOY_CFLAGS = $(TARGET_CFLAGS) $(subst $\",,$(BR2_TARGET_OPTIMIZATION)) -mfloat-abi=hard -ffast-math -funsafe-math-optimizations
  13. GNUBOY_CFLAGS += -ggdb -O3
  14. GNUBOY_CONF_OPTS += CFLAGS="$(GNUBOY_CFLAGS)"
  15. GNUBOY_CONF_OPTS += --prefix=$(TARGET_DIR)/usr/local --bindir=$(TARGET_DIR)/usr/games
  16. GNUBOY_CONF_OPTS += --without-fb \
  17. --without-svgalib \
  18. --without-x \
  19. --with-sdl
  20. GNUBOY_CONF_ENV += SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
  21. define GNUBOY_CREATE_OPK
  22. $(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/local/share/OPKs/Emulators
  23. $(HOST_DIR)/usr/bin/mksquashfs $(GNUBOY_PKGDIR)/opk/gb $(TARGET_DIR)/usr/local/share/OPKs/Emulators/gb_gnuboy_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  24. $(HOST_DIR)/usr/bin/mksquashfs $(GNUBOY_PKGDIR)/opk/gbc $(TARGET_DIR)/usr/local/share/OPKs/Emulators/gbc_gnuboy_funkey-s.opk -all-root -noappend -no-exports -no-xattrs
  25. endef
  26. GNUBOY_POST_INSTALL_TARGET_HOOKS += GNUBOY_CREATE_OPK
  27. $(eval $(autotools-package))