Browse Source

jh8100: spltool-native: Added spltool recipe

Added recipe for spl tool to sign jh8100 uboot spl binary.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 3 months ago
parent
commit
56a13b0feb

+ 30 - 0
recipes-bsp/starfive-tool/spltool-native_1.0.0.bb

@@ -0,0 +1,30 @@
+DESCRIPTION = "Starfive Tools"
+
+inherit native
+
+BBCLASSEXTEND = "native"
+
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI = "file://jh8100_cst.tar.gz"
+
+S = "${WORKDIR}/jh8100_cst"
+
+FILES:${PN} = "${bindir}/*"
+
+RDEPENDS:${PN} = "bash"
+
+do_compile() {
+	oe_runmake -C ${S}
+}
+
+do_install() {
+	install -d ${D}${bindir}
+	install -d ${D}${bindir}/input_files/jh8100
+	install -m 0755 ${S}/input_files/jh8100/scpbl_nor.cfg ${D}${bindir}/input_files/jh8100/scpbl_nor.cfg
+	install -m 0755 ${S}/mkbif ${D}${bindir}
+	install -m 0755 ${S}/create_hdr ${D}${bindir}
+}

+ 0 - 13
recipes-bsp/starfive-tool/starfive-tool.bb

@@ -6,14 +6,9 @@ LIC_FILES_CHKSUM = ""
 LICENSE:starfive-visionfive2 = "GPL-2.0"
 LIC_FILES_CHKSUM:starfive-visionfive2 = "file://LICENSE;md5=e6dc25dc2418b8831c906d43809d8336"
 
-LICENSE:starfive-jh8100 = "CLOSED"
-LIC_FILES_CHKSUM:starfive-jh8100 = ""
-
 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
 SRC_URI:starfive-visionfive2 = "git://git@192.168.110.45/sdk/soft_3rdpart;protocol=ssh;branch=jh7110-devel"
-SRC_URI:starfive-jh8100 = "file://jh8100_cst.tar.gz \
-			"
 
 SRCREV:starfive-visionfive2 = "10f543ca35e14809a9b4e9df814b798aa4362d14"
 
@@ -23,16 +18,8 @@ do_compile:starfive-visionfive2() {
 	oe_runmake -C ${S}
 }
 
-do_compile:starfive-jh8100() {
-	oe_runmake -C ${WORKDIR}/jh8100_cst
-}
-
 do_install:starfive-visionfive2() {
 	install -Dm 0755 ${S}/spl_tool ${D}/${bindir}/spl_tool
 }
 
-do_install:starfive-jh8100() {
-	cp -r  ${WORKDIR}/jh8100_cst ${DEPLOY_DIR_IMAGE}/jh8100_cst
-}
-
 BBCLASSEXTEND = "native"